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Microstructure relates to optical and mechanical material properties.
• Product appearance: design, specification, and quality assessment.
• Product fingerprinting for tracability. (∗)
• Fluid flow control.
• Influence on sliding friction.
• Engineering of optical materials

(LEDs, lasers, waveguides, sensors, solar cells, etc.)

Needed for integrated control of appearance in additive manufacturing.

Why microstructure control?

(∗)

https://www.rel8.dk/

https://www.rel8.dk/


A selection of 3D printers

Material Extrusion: fused deposition
modelling (FDM), direct writing assembly
(DWA), . . . ;
 Powder: binder jetting, selective laser

sintering, . . . ;
 Lamination: laminated object

manufacturing (LOM), selective
deposition lamination (SDL), . . . ;
 Photopolymerization: stereolitography

(SLA), direct light processing (DLP), . . . ;



Slicing an object for 3D printing
 Triangle mesh representation.
Horizontal cross sections aligned with

the print layers.
 This sampling of cross sections leads to aliasing.
Antialiasing is done by averaging many samples.
 But how to use the resulting grayscale values?



What is a DLP printer?

 Photopolymer (resin).
 Vat.
 Building platform

(step precision: 1 μm).
DLP UV-projector

(2560 × 1600 micro-mirrors,
pixel pitch of 7.54 μm).
Membrane (optional).

 The projector can project grayscale images, but what is the effect?



Calibration of print parameters

 Projector calibration:
• fix exposure time;
• print calibration sample with

increasing intensity;
• fix intensity;
• print calibration sample with

increasing exposure time;

 Layer thickness: 18 μm;
UV LED amplitude: 230;
 Exposure time: 3 s;

projected pattern

print result in microscope

repeated print of pattern with
different parameter settings



Subvoxel growth control

 The curing process is non-linear:

 𝜏𝜏𝜏𝜏 𝐼𝐼 = �𝛼𝛼 + 𝛽𝛽 log(𝐼𝐼 − 𝛾𝛾) , for 𝐼𝐼 > 𝑒𝑒−𝛼𝛼/𝛽𝛽 + 𝛾𝛾
0 , for 𝐼𝐼 ≤ 𝑒𝑒−𝛼𝛼/𝛽𝛽 + 𝛾𝛾

 If we find 𝛼𝛼, 𝛽𝛽, and 𝛾𝛾, we can correct:

 𝑓𝑓−1 𝐼𝐼 = �𝑒𝑒
𝜏𝜏𝜏𝜏−𝛼𝛼
𝛽𝛽 + 𝛾𝛾, for 𝐼𝐼 > 0

0, for 𝐼𝐼 = 0



Subvoxel height measurements

 To estimate 𝛼𝛼, 𝛽𝛽, and 𝛾𝛾:
• print linear gradient;
• measure the surface height with a

resolution of 0.4 μm;
• find a fit and estimate the

parameters;

 𝛼𝛼 = 17.71 μm,
 𝛽𝛽 = 10.24 μm,
 𝛾𝛾 = −0.01



Antialiasing in the slicer

slice of a sphere

aliased cross
section

after anti-
alisiang



Microstructure control using DLP 
grayscale values

Using a smooth noise function 
to modify surface roughness by 
controlling noise amplitude 𝐴𝐴
and frequency 𝐵𝐵.

Example of noise 
used as projector 
pattern.

Printed output 
as observed in 
microscope.

𝐴𝐴 = 0.625 𝑨𝑨 = 𝟐𝟐 𝑨𝑨 = 𝟑𝟑
𝑆𝑆𝑞𝑞 (𝜇𝜇m) 2.82 4.20 6.94 𝐵𝐵 = 16

𝑆𝑆𝑞𝑞 (𝜇𝜇m) 3.64 5.71 10.10 𝐵𝐵 = 32

𝑆𝑆𝑞𝑞 is the root mean square height of a surface area.



Noise

Noise explorer: 
https://people.compute.dtu.dk/jerf/code/noise/

 Sparse convolution noise
• Convolution of randomly placed (𝒙𝒙𝑖𝑖,𝑗𝑗) 

impulses of random value (𝛼𝛼𝑖𝑖,𝑗𝑗).
• Use a filter kernel with compact support 

and insert a regular grid (cell vertices 𝒒𝒒𝑖𝑖).

cubic 𝒗𝒗 = � 1 − 4 𝒗𝒗 ⋅ 𝒗𝒗 3 for 𝑣𝑣 ⋅ 𝑣𝑣 <
1
4

0 otherwise
• Use a seeded RNG: rnd(𝑡𝑡)
• Choose a number of impulses per cell (𝑁𝑁).

noise 𝒑𝒑 =
4

53 𝑁𝑁
�
𝑖𝑖=0

7

�
𝑗𝑗=1

𝑁𝑁

𝛼𝛼𝑖𝑖,𝑗𝑗 cubic(𝒙𝒙𝑖𝑖,𝑗𝑗 − 𝒑𝒑)

𝒙𝒙𝑖𝑖,𝑗𝑗 = 𝒒𝒒𝑖𝑖 + 𝝃𝝃𝑖𝑖,𝑗𝑗
𝛼𝛼𝑖𝑖,𝑗𝑗 = rnd 𝑡𝑡𝑛𝑛𝑖𝑖,𝑗𝑗 1 − 2 𝑗𝑗 mod 2

𝝃𝝃𝑖𝑖,𝑗𝑗 = rnd 𝑡𝑡𝑛𝑛𝑖𝑖,𝑗𝑗+1 , rnd 𝑡𝑡𝑛𝑛𝑖𝑖,𝑗𝑗+2 , rnd 𝑡𝑡𝑛𝑛𝑖𝑖,𝑗𝑗+3
𝑛𝑛𝑖𝑖,𝑗𝑗 = 4 𝑁𝑁𝒒𝒒𝑖𝑖 ⋅ 𝒂𝒂 + 𝑗𝑗

𝒒𝒒𝑖𝑖 = 𝒑𝒑 −
1
2 ,

1
2 ,

1
2 + 𝑖𝑖 mod 2,

𝑖𝑖
2 mod 2,

𝑖𝑖
4 mod 2

My choice: 𝑁𝑁 = 30 and 𝒂𝒂 = (1, 1000, 576)

0.5 𝐴𝐴 noise 𝐵𝐵 𝒑𝒑 + 1
𝐴𝐴 = 1,𝐵𝐵 = 1

https://people.compute.dtu.dk/jerf/code/noise/


Control of surface roughness in 3D
 The noise function accepts a 3D positions as input, so we can directly 

use it in our slicer and control the roughness of a 3D surface.

𝐴𝐴 = 2 𝐴𝐴 = 3𝐴𝐴 = 0.625no grayscale



BRDF and printer ground noise

ground 𝒑𝒑 =
2
3

noise
𝒑𝒑

50 𝜇𝜇𝜇𝜇
+

1
9

noise
𝒑𝒑

25 𝜇𝜇𝜇𝜇
+

1
12

noise
𝒑𝒑

2 𝜇𝜇𝜇𝜇



Noise-based 
modeling

 Noise with octaves
• Number of octaves Ω ≥ 1
• Lacunarity ℓ > 1
• Fractional increment (roughness) 𝐻𝐻 ∈ 0,1

fBm 𝒑𝒑 = �
𝑖𝑖=0

Ω−1

ℓ−𝐻𝐻𝐻𝐻noise(𝒑𝒑 ℓ𝑖𝑖)

• 𝐻𝐻 = 1 is a monofractal
(same fractal dimension everywhere)

 Absolute value for sharp edges

turbulence 𝒑𝒑 = �
𝑖𝑖=Ωlow

Ωhigh
1
2𝑖𝑖

noise(2𝑖𝑖 𝒑𝒑)

Top rows: input from marble images

Kim Harder Fog. Noise-based texture synthesis by analysis of image examples.
MSc thesis, Technical University of Denmark, 2017.

Bottom rows: fBm fit



Anisotropic surface reflectance
 Random rough surfaces produce isotropic reflections.
 Scattering is independent of sample orientation.

 Structured surfaces can produce anisotropic reflections.
 Example: ridged surface

m

V-grooves

Identical 2x2 cm2 samples.
Every ridge is 50 µm.
Slope angle is 𝜃𝜃𝑚𝑚 = 5∘.
Two samples have been rotated 90∘
as compared with the other two.
[Luongo et al. Modeling the anisotropic reflection of surfaces with microstructure
engineered to produce visible contrast after rotation. ICCVW 2017]



Line integral convolution
Given a 3D noise function like sparse convolution noise:

• For each pixel take the integral along a line.

Obtain a tangent space of
your 3D surface to be printed.
https://people.compute.dtu.dk/jerf/code/hairy/

+

References:
- Battke, H., Stalling, D., Hege H.-C. Fast line integral convolution for arbitrary surfaces in 3D. In Visualization and Mathematics, pp. 181-195. Springer, 1997.
- Frisvad, J. R. Building an orthonormal basis from a 3d unit vector without normalization. Journal of Graphics Tools 16(3):151-159, August 2012.

https://people.compute.dtu.dk/jerf/code/hairy/


Anisotropic smileys 
(ridges and sinusoids)

Top row: 3D printed
Middle row: computed
Bottom row: direction of incidenceInput texture and microscope images.



Print results



 Red: measured.
 Blue: predicted by analytic model.

Testing the optical function of an 
engineered surface

Confocal microscope image



Measuring surface microgeometry

Alicona Infinite Focus
• Non-contact
• Optical
• Depth by focus-variation
• Vertical resolution depending on 

choice of magnification
• From x2.5: 2300 nm 
• Down to x100: 10 nm

• Min. measurable roughness:
• 𝑆𝑆𝑎𝑎: 3.5 down to 0.015

(arithmetic average height)

• Output: xxx.al3d file



Inspecting and correcting 
the data

 Free tool for analysis of height fields obtained by microscopy
Gwyddion: http://gwyddion.net/

 File→Open... (it opens .al3d files)
 Data inspection: Tools – Read horizontal and/or vertical profiles

Mode: cross / horizontal / vertical (click the image to extract a profile)

 Data correction (outlier removal and adjustment of base):
• Data Process→Correct Data→Mask of Outliers

Data Process→Correct Data→Remove Data Under Mask
Data Process→Mask→Remove Mask

• Data Process→Level→Flatten Base

 Process: Remove outliers, flatten base, remove outliers

 File→Save as... (store processed data as a .gwy file)

http://gwyddion.net/


Profilometry and data 
export

 Cutout: Use the Crop data tool with Create new image checked

 Roughness measurement along a line:
Use the Calculate roughness parameters tool

 Surface roughness: Use the Statistical quantities tool

 Export using File→Save as...
Choose an image file type (.png, for example)
Remove decorations (Value scale, Lateral scale, frame, etc.)

Note the physical width of the 
image and the physical depth that 
the grayscale values correspond to. 
These are available from the 
Statistical Quantities tool.



Height map to mesh by 
displacement mapping

We can use Blender for this task https://www.blender.org/
 Following a tutorial https://johnflower.org/tutorial/make-mountains-blender-heightmaps

• Open Blender and delete the default cube (press del)
• Add→Mesh→Grid (increase X Subdivisions and Y Subdivisions in Add Grid)
• Import the height map as a texture
• Apply texture to grid as a displacement map
• Set Strength to physical depth divided by physical width
• Set shading to smooth (right click and select Shade Smooth)
• File→Export→Wavefront (.obj)  [you can uncheck Include UVs]
• This produces xxx.obj and xxx.mtl
• Edit xxx.mtl (set illum 4 and Ni 1.5)
• Ni is the assumed index of refraction

https://www.blender.org/
https://johnflower.org/tutorial/make-mountains-blender-heightmaps


Two meshes – how to 
combine?



Models at different scales
We divide the microscopic scale into

• Nano/micro: models considering
explicit microgeometry.

• Micro/milli: models using particle size or
microfacet normal distribution functions.

We divide the macroscopic scale into
• BSSRDF: models where the points of

incidence and emergence are different.
• BRDF/BTDF: local models for

opaque/thin objects.

sphere cylinder raindropprofilometry

normal distribution particle size distribution

BSDF

BTDF

BSSRDF

BRDF

microsurface particles



Macro and micro surface

m

 The BSDF defines the ratio of 
light incident in a surface point 𝒙𝒙
from a direction 𝜔𝜔′ that scatters 
into another direction 𝜔𝜔.
 The BRDF 𝑓𝑓𝑟𝑟 is the reflectance 

part of the BSDF.

n

x

ω’
ω

glossy BRDF f (x, , )r ω’ ω

The microsurface defines the geometry 
of a differential area d𝐴𝐴 at a position 𝒙𝒙 on 
the macrosurface.



Progressive unidirectional 
path tracing

1. Generate rays from the camera through pixel positions.
2. Trace the rays and evaluate a measurement equation

for each ray.
3. Randomize the position within the pixel area to Monte

Carlo integrate (measure) the radiance arriving in a pixel.

 Noise is reduced by progressive updates of the measurement.
 Update the rendering result in a pixel 𝐿𝐿𝑗𝑗 after rendering a new

frame with result 𝐿𝐿new using
𝐿𝐿𝑗𝑗+1 =

𝐿𝐿new + 𝑗𝑗𝐿𝐿𝑗𝑗
𝑗𝑗 + 1

 Progressive (stop and go) rendering is convenient for several reasons:
• No need to start over.
• Result can be stored and renfined later if need be.
• Convergence can be inspected during progressive updates.

p0

p1

p2

p3

http://www.pbr-book.org/

http://www.pbr-book.org/


Computing a surface BSDF 
from microgeometry

 One randomly placed sample per pixel (jitter sampling):

 Since the constant emitted radiance cancels out, we set 𝐿𝐿𝑒𝑒 = 1.
 Suppose we always choose either reflection or transmission:

• Russian roulette with 𝑅𝑅 𝑚𝑚,𝜔𝜔𝑖𝑖 as the probability of reflection.

 The Monte Carlo estimator is then

𝑓𝑓𝑠𝑠 𝒙𝒙,𝜔𝜔ℓ,Ω𝑟𝑟 =
1

4|𝜔𝜔ℓ ⋅ 𝑛𝑛|
�
𝑗𝑗=1

𝑁𝑁

𝐿𝐿𝑜𝑜,𝑗𝑗 |𝜔𝜔𝑜𝑜 ⋅ 𝑚𝑚| 𝜔𝜔𝑜𝑜 ∈ Ω𝑜𝑜

 𝜉𝜉 ∈ 0,1 is a continuous, uniform, random variable.
 We compute 𝐿𝐿𝑜𝑜,𝑗𝑗 by path tracing the microsurface (see Falster et al. [2020]).
 For translucent materials, we need to combine this with subsurface scattering.

−1 1𝒙𝒙𝑗𝑗

−𝜔𝜔ℓ

𝒐𝒐 𝑛𝑛 = (0,0,1)

𝑚𝑚 𝜔𝜔𝑠𝑠

Ω𝑜𝑜

𝜔𝜔𝑠𝑠

pixel

𝑁𝑁 = 𝑊𝑊𝑊𝑊, pdf 𝒙𝒙j =
1
𝐴𝐴

, Ω𝑟𝑟 cosΘ𝑟𝑟 ≈
4
𝑊𝑊𝑊𝑊

Falster, V., Jarabo, A., and Frisvad, J. R. Computing the bidirectional scattering of a microstructure using scalar diffraction theory and path tracing.
Computer Graphics Forum (PG 2020) 39(7). 2020. To appear.

https://people.compute.dtu.dk/jerf/papers/wptbsdf.pdf


Appearance acquisition and 
specification

29

xrite TAC7 scanner
https://www.xrite.com/tac

https://www.xrite.com/tac


Appearance Exchange Format

30



Rendering material appearance

31
The new 'Translucent Medium' material in KeyShot 9.2. Model: DK - LEGO Architect London

https://luxion.com/

https://grabcad.com/library/lego-architecture-london-21034-1
https://luxion.com/


Appearance assessment

32

 Suggested pipeline to generate digital master



Research
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1 

2 3 

Stets, J. D., Dal Corso, A., Nielsen, J. B., Lyngby, R. A., Jensen, S. H. N., Wilm, J., Doest, M. B., Gundlach, C., Eiriksson, E. R., Conradsen, K., Dahl, A. B., Bærentzen, J. A., Frisvad, J. R., and 
Aanæs, H. Scene reassembly after multimodal digitization and pipeline evaluation using photorealistic rendering. Applied Optics 56(27):7679-7690, September 2017.

Luongo, A., Falster, V., Doest, M. B., Li, D., Regi, F., Zhang, Y., Tosello, G., Nielsen, J. B., Aanæs, H., and Frisvad, J. R. Modeling the anisotropic reflectance of a surface with 
microstructure engineered to obtain visible contrast after rotation. In Proceedings of IEEE International Conference on Computer Vision Workshop (ICCVW 2017), pp. 159-165. October 2017.

Regi, F., Doest, M. B., Loaldi, D., Li, D., Frisvad, J. R., Tosello, G., and Zhang, Y. Functionality characterization of injection moulded micro-structured surfaces. Precision Engineering 60, 
pp. 594-601. November 2019.

Luongo, A., Falster, V., Doest, M. B., Ribo, M. M., Eiriksson, E. R., Pedersen, D. B., and Frisvad, J. R. Microstructure control in 3D printing with digital light processing. Computer Graphics 
Forum 39(1), pp. 347-359. February 2020.

Falster, V., Jarabo, A., and Frisvad, J. R. Computing the bidirectional scattering of a microstructure using scalar diffraction theory and path tracing. Computer Graphics Forum (PG 2020) 
39(7). 2020. To appear.

Hannemose, M., Doest, M. B., Gregersen, S. K. S., Wilm, J., and Frisvad, J. R. Alignment of rendered images with photographs for testing appearance models. Applied Optics.
Submitted. 2020.

1. Image comparison
[Stets et al. 2017; Hannemose et al. 2020]

2. Estimate appearance parameters
[Stets et al. 2017; Regi et al. 2019; Luongo et al. 2020; Hannemose et al. 2020]

3. Find good appearance model
[Luongo et al. 2017; Luongo et al. 2020; Falster et al. 2020; Hannemose et al. 2020]

https://people.compute.dtu.dk/jerf/papers/reassembly.pdf
https://people.compute.dtu.dk/jerf/papers/ridges.pdf
https://doi.org/10.1016/j.precisioneng.2019.07.014
https://people.compute.dtu.dk/jerf/papers/subvoxel.pdf
https://people.compute.dtu.dk/jerf/papers/wptbsdf.pdf


Photo-render alignment method
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 Requirements:
• Images of the object of interest.
• Camera calibration.
• Segmentation of images into object, background, and shadow.
• CAD model (polygon mesh).



Photo-render alignment and 
appearance models

35



Developing appearance models

 The Stanford bunny printed by the described DLP printer.



Developing appearance models

 Cupped angel printed using a commercial SLA printer (Peopoly Moai) 
and a transparent resin by AddiFab.



Developing appearance models

 3D scanned aluminium bust (depicting H. C. Ørsted).
Model for spatially varying roughness 𝛼𝛼𝑔𝑔 based on the mean 

curvature normal 𝑯𝑯 and the surface normal 𝑛𝑛.



Jeppe Revall Frisvad
Technical University of Denmark
jerf@dtu.dk
https://people.compute.dtu.dk/jerf/

https://people.compute.dtu.dk/jerf/
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